Why can I not play Freedom Cry?

  1. I recently bought Freedom Cry from Playstation Network. I downloaded it (or atleast I thought so) and tried to play it. There's nothing different at the main menu (I know Aveline is supposed to be there, but she isn't) and nothing in-game helps. So I went to 'My Downloads' and it says it has been installed. Then I went to the in-game 'additional content' and it says Freedom Cry is 'purchased' but not 'installed'. What is going on here? I tried downloading/installing it several times now, to no avail.

    User Info: NWaldinger

    NWaldinger - 3 years ago


  1. Go to 'My Downloads' and click on whatever you have downloaded. Install the DOWNLOADABLE CONTENT(DLC pack) pack exactly where you have installed AC4, which will help the game accessing it. If you are still confused then the best way is install the game WITH the DOWNLOADABLE CONTENT(DLC pack) already there, which will save a lot of your time because the 'Freedom Cry' and 'Aveline' content will already be there. Download it or just purchase any Compact Disk, with the crack for both.

    User Info: ayushdgupta02

    ayushdgupta02 - 1 year ago 0 0

This question was asked more than 60 days ago with no accepted answer.

Answer this Question

You're browsing GameFAQs Answers as a guest. Sign Up for free (or Log In if you already have an account) to be able to ask and answer questions.