Anyone know how to fix a graphics issue with Age of Empires II: The Conquerors. Red grass/purple water?

  1. I have been a long time Age of Empires II player, and have once suffered from the classic red grass and purple water graphics issue that a lot of people suffer from. However, using one of the below solutions, it eventually corrected itself. Recently, I installed Windows 7, build 7100 as my main operating system. AoEII (Conquerors exp. too) did not work on the original Windows 7 build, but now does, however, no matter what I do, scouring the internet for solutions and ways to solve the problem the graphics issue of the red grass and purple water stay. Here are the solutions I've read about and tried, all to no avail.

    Changing the resolution
    Alt tabbing
    Opening a folder before the game loads
    Unchecking "CPU 1" on the "Set Affinity" box in Task Manager
    Updating graphics drivers to most recent
    Updating DirectX to most recent
    Running the game in compatibility mode for XP, Vista, 98, etc.

    None of these solutions work at all, the green grass is still red, and the water is still purple.

    Here are my system specs.

    Windows 7 Ultimate 64-Bit Build 7100
    AMD Athlon 64 6000+ ~3.0GHz
    2GB RAM
    NVIDIA GeForce 8800 GT
    Direct X 11
    Running at 1920x1080

    Can anyone recommend any other solution to the graphics problem? Thanks.

    Here's a picture of the issue (screenshotting doesn't show the graphics problem)

    User Info: Psychochria

    Psychochria - 8 years ago

Accepted Answer

  1. Turns out all you need to do is alt-tab out of the game, and end explorer.exe from the task manager. This gives you flawless colours.

    User Info: Psychochria

    Psychochria - 7 years ago 0 0

Other Answers

  1. An easier way is to adjust the screen size. (it worked for me)

    User Info: nightglow95

    nightglow95 - 8 years ago 0 0
  2. When I play in Vista, I get that error all the time. I just use ctrl + alt + delete to get to the task manager (faster than alt + tabbing). Sometimes I have to do it 6 or 7 times in a row before the problem is fixed.

    See if that works for you. Like I said, you might have to do it a number of times until it is fixed.

    User Info: BigC_072

    BigC_072 - 8 years ago 0 0
  3. Ok, was looking for a solution for quite a while. This site has a neat guide about it:

    It was the program that fixed things for me in the end, I never tried running AoC in a window. I just like my classics classically I guess. So good luck!

    User Info: francis2557

    francis2557 - 8 years ago 0 0

This question has been successfully answered and closed.