How can we enable the console command?

  1. And does it work on an already started game?

    User Info: thrawn2034

    thrawn2034 - 7 years ago
  2. Additional Details:
    I'm a bit lost( I don't know about computers), im using windows vista and im trying to create the shortcut but is not working, im probably doing it wrong. Any more specific hints?

    User Info: thrawn2034

    thrawn2034 - 7 years ago
  3. Clarification Request::
    Hi i m using window vista i still didn get console work and idk wat is goin can someone tell me about it?

    User Info: reborn08

    reborn08 - 7 years ago
  4. Clarification Request::
    I am running into the same problem as Reborn, and infantryman.

    Vista wouldnt let me change the target via the shortcut because the names dont match. Added the -enabledeveloperconsole and no go. Added that to the end of the .exe and it will accept the changes on the target field in the shortcut. Changed the keymapping to ` to turn on console in game. I know I cannot see the console in game under Vista, but when I hit the ` for console, and type it does nothing. It will open various windows in the game and I can still move.

    Is this only workable in XP or am I doing something stupid?

    User Info: Kaldor9051

    Kaldor9051 - 7 years ago
  5. Clarification Request::
    Hmm I don't know about everyone else, but my console seems to be working, even though I can't see the bunch of letters or anything, but my normal hotkeys don't function and I can't move, which should mean it's enabled. However, none of the commands I type into it work. The exp one didn't work, the gift thing, the money thing and I simply died trying the godmode one. Sooo... any ideas what's up with that...?

    User Info: kasawagi

    kasawagi - 7 years ago

Top Voted Answer

  1. Add a shortcut to the daorgins.exe file in the bin_ship folder. add
    -enabledeveloperconsole to the end outside of the quote marks with a space inbetween.

    Now when in game press the tilde key to open the console. There will be no text entry field to show you are in the console, But after you start the first command you will see a bunch of random letters at the top of your screen.
    Enter the following codes and press enter, then tilde again and then enter again.

    runscript addxp x x=desired xp
    runscript zz_money x x=desired copper
    runscript pc_immortal god mode (still take damage)
    runscript zz_addparty NPCname add party member by name
    runscript zz_addapproval x adjust party members approval
    runscript ai off turn off the AI
    runscript selectparty party selection screen
    runscript chargen select origin screen
    runscript killallhostiles

    I havent tested all of these. Please note that you do not add -enabledeveloperconole to the default shortcut, that shortcut is to the launch menu, not the exe file. create a shortcut to the daorigins file mentioned above.

    User Info: dograw75

    dograw75 - 7 years ago 10 0


  1. edit or create a new shortcut for the game and add "-enabledeveloperconsole" to the end, then inside the game hit the tilde (~) key to open the console.

    After that you can type:
    "runscript addxp X" where is is the amount of experience you want.
    "runscript zz_money X" where X is the copper you want
    "runscript pc_immortal" You will still get damaged, but you won't die when your health reaches 0.

    User Info: Insaniac99

    Insaniac99 - 7 years ago 3 1
  2. I've tested most of dograw's devconsole codes.
    So far, addxp, zz_money, pc_immortal, addapproval, ai, and killallhostiles work as they should.
    I haven't tried add_party, selectparty, and chargen as I didn't see a need for it.
    there's probably an additem code, but I think it works in the same manner as NWN additem codes worked, (i.e. nwn_item_name_02)

    note on addapproval, you have to select the character whose approval you want to increase for the code to work properly
    (i.e. click on Morrigan and enter the code and her approval will go up, otherwise it'll just stay as is)

    User Info: tod_engel

    tod_engel - 7 years ago 1 1
  3. You might have trouble making this work in Vista. I've played some other games on steam where I was unable to get the console working under vista.

    User Info: spthomas

    spthomas - 7 years ago 0 3
  4. The console will work just fine in Vista, but you wont be able to see it. After you do the steps to alter the shortcut to enable the console, enter your game and load up your save. Hit the ~ on your keyboard and enter the command ex: runscript addxp 10000 , then hit enter, ~ and enter again. Your game will be unfrozen, and you will be able to move freely.

    Its kinda annoying but should work just fine.

    User Info: Fyrewallz

    Fyrewallz - 7 years ago 0 1
  5. I can't get the console to open up, I followed all the directions and I made the key to open it in the game one that is not currently used. Any ideas? when i try to type it just opens up all the menus that would normally appear if you were to hit their hotkey.

    User Info: infantryman110

    infantryman110 - 7 years ago 0 0
  6. I have read elsewhere that you need to hit the backspace key before typing a command. I think it removes a ` character that is inserted when you hit the tilde key to open the console.. I can't see the console either, but I have done this and it has worked for me.

    User Info: Jarobsco

    Jarobsco - 7 years ago 0 0
  7. I'm on Windows 7 (so largely the same structure as Vista I guess), and it's working for me. Just follow the directions in the 'Cheats' section here, they should be clear. Also, I can verify that the console does also work for the Steam version of the game.

    User Info: Tha_Danus

    Tha_Danus - 7 years ago 0 0
  8. Infantryman110, you probably have an extra space for your console.

    For example instead of having:
    "F:\Dragon Age Origins\bin_ship\daorigins.exe" -enabledeveloperconsole

    You may have:
    "F:\Dragon Age Origins\bin_ship\daorigins.exe" - enabledeveloperconsole

    Make sure you do not have the extra space after the - or else it will not work. Hopefully that fixes it for you.

    User Info: DJSquirrelly

    DJSquirrelly - 7 years ago 0 0
  9. For the people using vista go to the "compatibility" tab under properties and check the box for "Run this program in compatiblity mode" and then select "windows xp service pack 2"

    User Info: dizzydevil69

    dizzydevil69 - 7 years ago 0 0
  10. I also am using Vista, (Ultimate, 64 bit version), and I did notice that I have to hit the ` (tilde) AND THEN the key that I assigned as the hotkey. One that thing that is frustrating me is since I cannot see the console, I'm not exactly sure if the console is turned off or not....

    Two other things to note:

    1) You'll know you got it enabled when you see white text with all the numbers, letters, (both capital and lowercase), and symbols across the top of your screen. At least, that's how I knew it was working....

    2)For those of you who have the collector's edition, this DOES work....

    User Info: EngBulldog

    EngBulldog - 7 years ago 0 0
  11. The best way to see that the console is enabled is that when the console IS enabled you can't do any action on the game itself.

    User Info: Starmoonz

    Starmoonz - 7 years ago 0 0
  12. Figured it out. It might help some. I have played NWN 2 before and i remembered that you had to open console there by pressing SHIFT + ` + ?. Its for non-US keyboard settings. Im estonian so im using estonian keyboard layout. ( Don't press + button, for some who didn't understand. :D ). I hope it helps.

    User Info: primegeneral

    primegeneral - 7 years ago 0 0
  13. One more thing. Before writing there anything press backspace, because when it opens console it adds ? mark there. After that add you script and it should work.

    User Info: primegeneral

    primegeneral - 7 years ago 0 0
  14. The only one I've tried so far is adding money, and it worked just as it should. I don't recall seeing anything confirming that, but when I opened my inventory, the extra money was there. I have the retail version of the game, purchased from

    User Info: Jarobsco

    Jarobsco - 7 years ago 0 0

This question has been successfully answered and closed.