Why can I not progress through Fort Sprocket?

  1. I'm in Fort Sprocket, right after the area where you see the robots manufacturing the bolts and pick the lock to open and use the platform that throws you over into that area. You defeat two waves of robots and then enter a warehouse-type area with three patrolling robots and a big platform that is supposed to rise to take you into the next area. (The level's second TV is under this lift.) The honeycomb-type doors close behind you.

    Here's my problem: the lift doesn't rise. Ever. I've tried blitz attacking and defeating all the robots, I've stealth-attacked and defeated all three of the robots (but I somehow still alert some offscreen robots somewhere, one of which comes flying down from above and goes through the floor in a glitch and ends up walking in place with just his antennae sticking out of the floor), I've tried just sneaking through... everything. Is there a really well hidden switch that I'm missing? I thought it might have to do with the glitchy floor robot, so I placed a man-eating plant (forget the name now) to catch him as he fell, and it did and destroyed him, but even then no elevator/lift action.

    What am I doing wrong? Am I just an idiot who's missing something really obvious?

    I'm playing the PS2 version on the PS3. I already exchanged the game once and had the same problem, so I created a whole new virtual memory card and new game in case my save was corrupted. Played all the way back and had the same issue.

    Anyone have any insight?

    User Info: sugarmama71

    sugarmama71 - 8 years ago
  2. Clarification Request:
    I thought it was just me. I am also playing the game on my PS3 and you have the exact problem I am having. I have tried all ways of defeating the robots in that room and couldn't figure out what I was doing wrong. I guess I will have to begin again on my PS2. The only thing is while I was playing R&C TOD, there was an area where I found something that I thought was was supposed to help in this game.

    My questions to you. Have you noticed how hard it is to move the characters with the joystick on the controller? I get so frustrated when I can't move the characters.

    User Info: merltie2

    merltie2 - 8 years ago
  3. Additional Details:
    Oh merltie2... I feel your pain, believe me. After finally playing through the entire game again - and that section - on the PS2, I am afraid to even try it again on my PS3. And, yes, it is very difficult to move with the joystick! Funny, I thought I just had a crappy controller. I would find especially that Clank would slow down at the worst times and just start walking. No, dammit, RUN!!!

    User Info: sugarmama71

    sugarmama71 - 8 years ago


  1. Notice the red buttons on the lift? You'll need to step on one of them to activate the lift. If that doesn't do it, maybe it's the fact you're playing on Ps3 (I wouldn't know, I only have the PS2). If that isn't the case, I would call up Sony or the publisher and complain the disc has a worksmanship defect- I don't think anything else could have caused the problem. I had no problems getting past that area at all. (But don't call yourself an idiot! I have had many of those "duh- that's how I was supposed to do it" moments with video games! :p)

    User Info: superfly96

    superfly96 - 8 years ago 0 1
  2. Superfly, thanks so much for your response. It turns out that it's just a problem on the PS3 - I pulled out the trusty old PS2 and played through without a problem. I did contact Sony about the problem and got a standard response, so I don't know if they'll actually address this problem. I'm just glad that I'll actually get to finish the game!

    Man, the load times on the PS2 are long!

    User Info: sugarmama71

    sugarmama71 - 8 years ago 0 1
  3. This is not about the topic, but I think you strafe by using the directional pad instead of using the joystick.
    (I play the PSP version and it works, so I'm not sure about PS2/PS3)

    User Info: Sn0oze

    Sn0oze - 8 years ago 0 0
  4. I've run into cases where enemies are rendered off-screen and the exits stay locked tight until they're defeated. For me (PS2 release, PS2 console, DualShock2) it's happened most at the start of Venantonio, when an amoeboid gets stuck high up the wall or completely out of sight. A small one got knocked off kilter or was vomited up there more than once.

    That platform is an exit and won't rise until every enemy is taken care of. Cufflink bombs are good at targeting unseen enemies; watch for when its reticle on the floor suddenly disappears. But try all of your weapons, and changing your position, too.

    If nothing works, use Options > Load (from last Continue) and then approach the fight completely different. Don't bother with the stealth takedowns; jump on the cart with a nanotech crate and fight from there instead. Let them come to you, then toss a tanglevine carnation and use the solid crate as a shield.

    User Info: falconesque

    falconesque - 5 years ago 0 0

This question was asked more than 60 days ago with no accepted answer.

Answer this Question

You're browsing GameFAQs Answers as a guest. Sign Up for free (or Log In if you already have an account) to be able to ask and answer questions.