Weird glitch where I cannot load my game?

  1. Ok i finally found all the parts for the invent part to bring back life to arcadia. Im walking along fighting and I get to the part where someone is opening the door with a torch and I save at that point and now when I load my game it just freezes the hdd light doesnt even go on or blink once. has this ever happened to anybody?

    User Info: lordsolidusx

    lordsolidusx - 8 years ago
  2. Additional Details:
    the item to invent was the Lazarus Vector

    User Info: lordsolidusx

    lordsolidusx - 8 years ago

Top Voted Answer

  1. This has long been answered so please close it ASAP!!!

    User Info: itwizz

    itwizz - 7 years ago 1 0


  1. The reason most likly for this to have happend is probably because the harddrive probobly reads the data as corroupted data and therefore will not load it im sorry to say this but you might have to start over from the start again but hey its not a long game i beat it and got all the trophies in under a week.

    User Info: Malkavious

    Malkavious - 8 years ago 1 0
  2. I have a simular problem, my game loads up properly, its just when i try to leave the area to return to arcadia, while loading it freezes. Ive tried starting again, but still happens

    User Info: grantman88

    grantman88 - 8 years ago 1 0
  3. Unfortunatley something has gone wrong with your save data and there is no way to fix it. You are just going to have to start over.

    User Info: Glokwerk

    Glokwerk - 8 years ago 1 0
  4. That's a game data problem. I had it with this and MGS4. What I did was erase all data related to the game and installed it back again. And it worked perfectly.

    User Info: LordReyson

    LordReyson - 5 years ago 0 0

This question has been successfully answered and closed.

More Questions from This Game