Cannot connect to game provider?

  1. When im signed in at PS Network, I go to multiplayer in GTA, but when i press on multiplayer it says "Cannot connect to game provider, please try later?" Is something wrong?

    User Info: Tala_M

    Tala_M - 8 years ago
  2. Additional Details:
    Thanks guys, they're really helpful answers i forgot to mension after sometime it signs in, but thanks anyways.

    -Thanks for your help.

    User Info: Tala_M

    Tala_M - 8 years ago

Accepted Answer

  1. ^No, I don't think that's it. I've had that before, waited and tried later like it tells you to, and it worked fine. The "something wrong" is that it can't connect. You answered you're own question, pretty much.

    User Info: GuitarHero465

    GuitarHero465 - 8 years ago 0 0

Other Answers

  1. That means that on the GTA 4 you bought the makers messed up on the multiplayer part so your ps3 cant read it

    User Info: jrp93j

    jrp93j - 8 years ago 0 0

This question has been successfully answered and closed.