My PSP can't read the UMDs.(?)

  1. I wanted to play Crisis Core earlier today but when I put in the UMD it wouldn't load (the loading icon was showing but that's it) I went to the website and tried everything I could without an active warranty (it expired last Christmas) and it still doesn't work. So does anyone know anything I could do to make it work even if ie means opening the PSP and messing with it (warranty's void anyway)? If it helps anyone it still reads Memory Sticks and can still show pictures and play music, also it makes a
    scratching noise while it tries to load the UMD.

    User Info: Frankie123457

    Frankie123457 - 8 years ago

Top Voted Answer

  1. I had a similar problem with mine. The problem I had was the Magnetic UMd Holder has a small metal nub that held the UMD to the holder had come off and was stuck in the UMD and when I Placed it in the PSP the Nub stuck on the Spinner in the PSP so the UMD's I placed afterwards wouldn't play. check to see if something is on the spinner in the PSP

    User Info: Norm728

    Norm728 - 8 years ago 2 0


  1. The scratching noise means the umd is dirty this has happened to me many times try to wipe down the disc with a cloth that wont scratch it and see if that helps if not then try another umd to see if its maybe ur psp

    User Info: Notorious_KGB

    Notorious_KGB - 8 years ago 0 2
  2. i had a friend who wanted me to take a look at his since he lent it to someone. and it came back with disc read errors.

    ive had it discread error on my own psp befor. but when i upgraded it started reading again.

    as well... if you just let it keep trying to read the disc about 2 minutes i assume that you get the message telling you the umd cannot be read.

    a few people have suggested using something like a qtip to gently push the laser all the way to the side and than try to read again. my friends problem was actualy that the bar that spins to make the laser move back and forth wasnt catching right on the guide pin. if you ever have taken apart a ps2 youll know what i mean. its the same way. one bar is treaded like a screw. you could try moving the laser with the qtip. than apply a little pressure to the plastic guidepin(NOT the laser). hopefly if thats the problem it will hook back to the tread and start reading again.

    didnt have to take appart the psp for this though, you can do it through the open UMDdrive door

    User Info: TheDecepticons

    TheDecepticons - 8 years ago 0 2
  3. become a pirate!!! X)
    joking aside, i saw a site that sold replacement umd readers in the psp.
    maybe buy it and try to fix it yourself. No use in having a psp without being able to play games

    User Info: firin_me_lazars

    firin_me_lazars - 8 years ago 0 1
  4. I had the same problem myself. If you update it and it still doesn't work, then it is the same problem I had.

    What has happened is the lens has been damaged. If you've dropped it before, or moved it suddenly with some force, it could have scratched, moved etc. It could even have piled on some dust.

    To fix it, you can try a couple things. If you open the UMD slot, you should be able to see the lens. If you try wiping it with a qtip or something, that could work. If that doesn't work, the only real way to fix it is to get it properly fixed.

    User Info: darksteel88

    darksteel88 - 8 years ago 0 0

This question has been successfully answered and closed.