Why won't the UMD play?

  1. I have tried to play a UMD, and it will wait on the green loading screen as I turn it on. After a while, it will say that the disk cannot be read. I have tried cleaning the laser with the qtip and pushed the trigger to make the laser come on. So the laser is not the problem, and the UMD has nothing on/inside it. I tried moving the spinner with the qtip, and it works. Anybody help?

    User Info: sangizkewl

    sangizkewl - 4 years ago


  1. 1. Is your UMD okay..? Have you tried using a diff UMD to make sure the UMD you are using isn't the problem?
    You could also try the said UMD on a diff PSP to see if it does work.

    2. Are the gears that move the lens stuck? Try moving it in the center or at the end. Pop in your UMD and see if the lens will move.
    Also, can you hear the UMD spinning?

    3. Are you on CFW? There are some plugins that you may be using that prevents a UMD from playing. (psppowersaver is a good example)

    User Info: filanimetor

    filanimetor - 4 years ago 0 0

This question was asked more than 60 days ago with no accepted answer.

Answer this Question

You're browsing GameFAQs Answers as a guest. Sign Up for free (or Log In if you already have an account) to be able to ask and answer questions.