How do I get to the flame dragon?

  1. I've gotten the parts of the song from the water and thunder dragons, and now Fi is telling me to go to Eldin to find the flame dragon. I can't find him there, and Fi isn't giving me any new hints.

    I can find three places that I haven't been to yet, but they have lava in the way. I have tried pouring water from bottles onto the lava to make a platform (didn't work). I've tried getting the beetle to grab one of those water-storing plants that is near one of them (they bust as soon as the beetle touches them).

    User Info: Marker_Mage

    Marker_Mage - 5 years ago
  2. Additional Details:
    I just tried repeatedly falling into Eldin, trying each of the bird statues that I could choose. I didn't get any cutscene. Am I going to have to start over and work my way back to this part again?

    User Info: Marker_Mage

    Marker_Mage - 5 years ago
  3. Clarification Request::
    Stupid question... Did you do Din's Silent Realm yet? If not, Dowse to find the location.

    If you did, you should be heading into that part of the volcano where your whole body sets on fire just because you walked into it.

    User Info: joegt123

    joegt123 - 5 years ago
  4. Additional Details:
    Yes, I have done Din's Silent Realm. I can go to the Thunder Dragon and do it again if I want to. I've even gotten the Hylian Shield from doing his little boss rush.

    The bokoblins haven't taken my items. How do I get them to take my items? I went to Zelda Informer and looked at their guide. I seem to be having trouble at the "But as you prepare to land, the volcano erupts, sending your flight off-course and forcing you to crash-land at the bottom of the volcano." part of the walkthrough. The Gamespot one doesn't seem to cover the part, and the Shiekah Stone won't tell me a thing about it.

    I could take some pictures with my 3DS if that would help.

    User Info: Marker_Mage

    Marker_Mage - 5 years ago
  5. Additional Details:
    I took and uploaded some pictures.

    What Fi is telling me to do.
    My current equipment. Note the two pieces of the song.
    One of the unexplored paths.
    A second unexplored path.
    A third unexplored path.

    I tried talking to Levias again before I took these pictures. If I have to bomb something, I have no way of identifying it. The only place that looks like it might be bombable is that area with the two lizalfos, but it has held up to the explosives.

    As you can see from the second picture, I do have a bug catching net. I don't have a friend with their own copy of the game. As for contacting Nintendo themselves, I would like to know how to go about doing that. It would seem that they are more focused on problems with the Wii than with games for the Wii.

    User Info: Marker_Mage

    Marker_Mage - 5 years ago
  6. Additional Details:
    I went to Eldin before doing the boss rush, so that wasn't the trigger.

    User Info: Marker_Mage

    Marker_Mage - 5 years ago
  7. Clarification Request::
    Pyralblitzzz may be right.Did you speak with golo the goron twice and save?If yes, you will have to delete your save file and start it over from the very beginning.

    User Info: lucasdpr

    lucasdpr - 5 years ago

Top Voted Answer

  1. Actually, this is a known bug in Skyward Sword. I had the exact same problem and I was tearing my hair out trying to find the fire dragon and finally caved and looked online - which led me to this information

    If you go to Thunder Dragon and complete that song piece first, then end up talking with the Goron in the zone, then do the Water dragon and end up going back to talk to that Goron again (or something like this) the game will not trigger the "automatic" event entering the fire realm that gets link captured and forces you to complete the fire dragon / song quest.

    However, you do NOT have to start your game all over again - Nintendo released a fix for this really annoying bug. If you go into the WiiShop, and go under the "Channels" - you'll see a special "Zelda Skyward Sword data recovery" channel. Download it, and then run it. It will fix your save game state (you won't lose anything) so the event can be triggered. Once your save state is repaired, just go out to the sky, then enter the fire realm and you'll be all set! This is the ONLY way you can continue on your adventure if you managed to trigger this bug!

    As a side note - make sure your save game data is on the internal wii memory and not on an SD card. The channel only fixes it if its on the internal memory.

    User Info: riffraff00

    riffraff00 - 5 years ago 2 0


  1. For me when I'd gotten both the water and thunder dragon's parts of the song, when I went to the Eldin area a cutscene occured as I was still falling from the sky. The events that followed led me to the fire dragon eventually. I remember I selected the first bird statue you come across when you first go to the Eldin area, so maybe you have to try to actually select that bird statue when landing in the Eldin area.

    User Info: MstrBlade

    MstrBlade - 5 years ago 0 0
  2. have you had to do the part where the bokoblin take your items and you have to retrieve them. I know, you said you didn't encounter a cutscene, but it's worth asking. when in doubt, either check the skyward sword guide, the gamespot one on here, or use the shiekah stone to get hints.

    User Info: cosplaykid21

    cosplaykid21 - 5 years ago 0 0
  3. Maybe try talking to the whale thing again and then going to the volcano... I went there straight after beating the parasite and the cutscene was triggered (even though I didn't intend to do that one first).
    Another possibility may be that there is a rock in the area somewhere that would block your path when you lose your items, so you may need to blow it up first and then re-enter the area to get the cutscene.

    User Info: DragonEleven

    DragonEleven (Expert) - 5 years ago 1 0
  4. do you have the bug catching net? I know this is a random question, but perhaps you need all 8 of the controllable usable items to do it. If that and none of the other answers help then you should try to contact and get help from nintendo themselves. At the very least they might know whether or not your game is faulty and be able to get you a new one... also, if you have a friend who has the game, see if they will let you use it to see if playing on their disc will activate it.

    User Info: cosplaykid21

    cosplaykid21 - 5 years ago 0 0
  5. After getting the thunder dragon's part of the song, did you do any of the boss rush, as this may be the cause of a glitch?
    I never hit this glitch, but out of curiosity I'm going to keep an eye out for more details of it... others are trying to find the true trigger for it as well as a solution, and I may join them if I have time.

    User Info: DragonEleven

    DragonEleven (Expert) - 5 years ago 0 0
  6. There are mentions of people who appeared to have triggered the glitch, becoming unable to activate one or both of the events for the fire or water dragons, but then it seemed to sort itself out and the event/s triggered normally when they went back to the area again.
    This could mean that there is some way that the glitch does correct itself, or a trigger that they have activated without realising.
    Until a solution is found all I can suggest is to try doing other things and checking back to see if the cutscene triggers... maybe just speaking to random characters.

    User Info: DragonEleven

    DragonEleven (Expert) - 5 years ago 0 1
  7. Well, i can say that my order was Water, Flame, And Thunder Dragon. Maybe this made the game to be unbeatable.

    User Info: NFMLH1

    NFMLH1 - 5 years ago 0 0
  8. Um.. This may have been asked already, but did you talk to Gorko the Goron twice during the thunder dargon's quest, as in activate the game breaking glitch? Because if you did, then there is no way to get past it. You'll have to restart from a point beforehand, or start over entirely.

    User Info: Pyralblitzzz

    Pyralblitzzz - 5 years ago 1 0

This question has been successfully answered and closed.