Why wont a guard talk to me to begin Blood on the Ice?

  1. I have entered and exited the city via fast travel 4 times. I fast traveled back and it was night time. I went to the grave yard and the people were standing around the dead body, but there was no guard to be found. I tried talking to the roaming guards but they dont offer anything.

    I was wondering if I am missing something that needs to be done or is it my game just glitched it?

    User Info: FAF101

    FAF101 - 5 years ago

Top Voted Answer

  1. It's probably glitched. This is one of the most broken quests I've ever seen. I got glitched at a different point in this quest than the one you're dealing with, then I reloaded a previous save (from well before I had even visited the city). I played partly through the quest the way it's intended, then when I got to the point where the objective is "Catch the murderer," it won't let me talk to him. All I can do is fight him until he gets to critically low health and then NOTHING! I can't talk to him, hitting him again doesn't kill him, in fact I get a bounty for "assaulting" him and the guards swoop in and haul ME off.

    Nice work, Bethesda, after the buggy mess that was Fallout: New Vegas, one would think you'd learn to hire more testers.

    User Info: thisnamerules

    thisnamerules - 5 years ago 2 0


  1. I think its glitched bc i cant even get the quest to trigger i have entered and exited the city many times have done the required quests and helped 6 people but no one ever shows up in the graveyard,

    User Info: DsRaVeN69

    DsRaVeN69 - 5 years ago 0 0
  2. Yeah. You are glitched. I'm a good bit into that quest now, but I'm stuck now. I completed the current objective, but it hasn't given me a new one.

    This quest may be glitchy, but it certainly is nothing like New Vegas. You can't even compare the amount of glitches. This is the only problem I have had.

    User Info: Mandalorian97

    Mandalorian97 - 5 years ago 0 0
  3. Figures.. One of the few side quests I do is the buggiest quest in the game.. I'm glitched in this one too.. >.>

    User Info: elmangos

    elmangos - 5 years ago 0 0
  4. yup, its glitched. I've spoken with the guard,the guy in the Jarl's hall, and the undertaker. The undertaker is shown as completed, the other two are open. It will get patched at some point.....or not. Kind of stupid to have the main story line of a city not work, but whatever. There are 800,000 other thing to do.

    User Info: sharkguy99

    sharkguy99 - 5 years ago 1 0
  5. it's glitched. Got the quest to trigger. it won't let me examine the scene.

    Why would bethesda hire more testers? They know we'll buy the game anyways, and essentially we become the testers. All they have to do is click on the gamefaq message boards to see all the glitches they need to patch, and it doesn't cost them a dime.

    User Info: dualblades

    dualblades - 5 years ago 1 0
  6. I'm there too. It says "Examine the crime scene". Nothing.
    While the quests in this game are glitched, the glitchiest things I've encountered are the dragons.
    Recently I have only had a problem with them flying in slow motion, but before they would just randomly spaz out in the sky, fly backwards, lose all detail and color, essentially reverting to a play-do model dragon, and a number of other things.

    User Info: Randomnul3

    Randomnul3 (Expert) - 5 years ago 0 0
  7. Why does bethesda make great games but they r so glichy u cant play them.

    User Info: NinjaX427

    NinjaX427 - 5 years ago 0 0
  8. I had the same problem with the guard not going into dialogue with me after I questioned the witnesses. I want to thank the submitter who said to punch a guard. That worked for me. I had completely forgotten that I picked up an unusual gem right in front of the wizzard and persuaded the guards to let it slip. Thank you! Problem solved.

    User Info: JoAnneTea

    JoAnneTea - 5 years ago 0 0

This question has been successfully answered and closed.