How do I fix the glitch in the Rescue From Fort Neugrad: Report to Ralof quest?

  1. *I'm on the xbox 360*

    Hey guys, so I've completed the Rescue From Fort Neugrad Quest. I've killed all the
    imperial soldiers and freed the Stormcloak prisoners. The only thing left is the "Report to
    Ralof" objective. But, everyt ime I go to speak with Ralof and press A, nothing happens. All I hear are greetings and I cannot go into a dialogue menu. Basically, RALOF WON'T SPEAK WITH ME. He's not angry or anything, I just can't get him to talk and therefore can't "report" to him. He just stands around the front entrance with all the freed prisoners.

    Has anyone else encountered this?

    And if so, is there a fix for it on the xbox 360 version?

    User Info: manbeastjoe

    manbeastjoe - 5 years ago
  2. Additional Details:
    @dethfade, I tried that whenever I had the problem, but it didn't work for me...I even killed all the bloody soldiers without alerting Ralof o__O

    However, I found my own solution quite by accident! I hadn't finished the main questline, so I just gave up on the liberation of skyrim (they could wait, I was jelly). Like halfway through the main, Ralof is required in one of the quests...I think to capture a hold. But anyways, as soon as the quest that included Ralof was activated, "Quest Completed: Rescue From Fort Neugrad" flashed across my screen. I was so freakin happy.

    User Info: manbeastjoe

    manbeastjoe - 5 years ago

Accepted Answer

  1. Check the info for the solution.

    User Info: manbeastjoe

    manbeastjoe - 5 years ago 0 0

Other Answers

  1. You have to finish killing all of the guards. Near where all of the troops stand there's an entrance into the Castle/Fort itself. There should be 8 more guards to dispatch that should be it, afterwards you don't even need to speak to Ralof.

    User Info: Blades_Artemis

    Blades_Artemis (Expert) - 5 years ago 0 0
  2. The answer by Blades_artemis does no good. It's glitched after killing and recusing everyone in fort nuegard, there is nothing you can do...Na't report back to Ralof, Try locacting ulfric in the camp where he assigned the mission, but as far as i know ralof is glitched.

    User Info: skyrim1991

    skyrim1991 - 5 years ago 0 0
  3. I had the same problem, but I found a way around it... It seemed like Ralof was constantly getting stuck in conversations with the Stormcloak soldiers, so I went and hid, turned into a werewolf, killed everyone besides Ralof, and ran away until I turned back...This let him say something about "holding down the fort all on his lonesome." He then told me to go and get a garrison for him. So just try killing all the stormcloak soldiers, but do it in werewolf form or without getting discovered because Ralof tends to hold a grudge...

    User Info: DethFade

    DethFade - 5 years ago 0 0
  4. Dethfade's is a life saver on this one, killing everyone does work pretty well. i don't think anyone was supposed to survive it anyway, but i was level 40 so i kind of merked everyone and was waiting to finish. but regardless what he said works thanks ^^

    User Info: Walter_Games

    Walter_Games - 5 years ago 0 0
  5. Dethfade is completly right. I jus poisned one and shot a couple of the other and it worked just like he said. Thanks man.

    User Info: RDub2205

    RDub2205 - 5 years ago 0 0
  6. So, I came to the same problem today while playing and I nearly cracked the sh*ts... But instead I just killed all of the Stormclock Soldiers that I rescued, and Ralof said something along the lines of "I can't believe we're the only survivors" or something, and after that it told me I had completed the quest...So went to Ulfiric and sure enough I beat the glitch...

    So, Kill the Stormcloak Soldiers (I even had a good ol' fight with Ralof, but he can't die, so it's okay) and then speak to him...

    User Info: TayDubs

    TayDubs - 5 years ago 0 0

This question has been successfully answered and closed.