Help!!!!!! I lost Serona/Serena!!!! Dawnguard DLC?

  1. Ok so I was messing around on Skyrim it's a long story but anywho I accidently told Serona "I think it's time to part ways." I figured it was no big deal so I went back to the fort thinking I could tell her to follow me, yeah that's not the case. I can only ask her if she will turn me into a Vampire or if she can make some special arrows for me so PLEASE SOMEONE ANYONE Help me out and get this chick to follow me. I deleted and redownloaded the DLC that didn't work, I have no previous saves, I reset my xbox. Nothing works please help me.

    User Info: Caboose2793

    Caboose2793 - 5 years ago
  2. Additional Details:
    Also this problem is taking place AFTER i've done all the quests for Dawnguard

    User Info: Caboose2793

    Caboose2793 - 5 years ago
  3. Clarification Request::
    Did she say anything about where you could find her? Did you check her mother's lab in the vamp castle? Did you check the garden or the main hall there? Just asking since I don't like followers, but I'd like to find her if I dismiss her.

    User Info: zero2935

    zero2935 - 5 years ago
  4. Additional Details:
    Pinkfloyd, tried your answer and it did not work, all i can say to her is "I want you to turn me into a vampire." and "I'd like to treat some arrows with your blood." this is all i can do and I've tried a lot of different methods but nothing seems to work.

    User Info: Caboose2793

    Caboose2793 - 5 years ago

Accepted Answer

  1. Ok so i figured it out I went to the Soul Cairn and told Serona's mom that Harkon is dead and that it's time to leave. Then Serona showed up, also I had an ally follow me before I went in there so maybe they gave me Serona as a substitute since she is able to go in when my ally is not I don't know but the point is I got Serona back.

    User Info: Caboose2793

    Caboose2793 - 5 years ago 0 0

Other Answers

  1. I would first try loading a save that she was following you in. If you don't have such a save the I would recommend going up to her, talk to her, exit the dialouge, save your game and the reload the save. Often character dialouge options disappear and reloading a save will cause them to reappear. I faced a similar problem during one of the Imperial Legion quests.

    Tell me how it turns out.

    User Info: pinkfloydX0

    pinkfloydX0 - 5 years ago 0 0

This question has been successfully answered and closed.