Academia 4XX Gate Seal issue?

  1. I missed three fragments, so I used the Academia 4XX gate seal and started the area over. I went through and got the fragments from New Bodhum Unknown, went through A Dying World, and made it back to the Crux. I tried to select Academia 500, and it won't allow the option. I tried going back to A Dying World, and it wouldn't let me. I can't go any earlier than Academia 4XX, it's cut off. Academia 4XX is the only area I can enter, and there is nothing left to do in there. I can't open the second gate in there, because I don't have a Wild Artefact, and no way to go anywhere else to get more. Any suggestions on what I did wrong and how to fix it?

    User Info: Predikit

    Predikit - 5 years ago

Accepted Answer

  1. You have to re-open the gate to be able to go to other areas again. Just press RB again and you should be able to go around the historia crux normally again.

    User Info: ox0shadow0xo

    ox0shadow0xo - 5 years ago 0 0

This question has been successfully answered and closed.