Miraak glitch? (SPOILERS)

  1. So I seem to be having the same glitch as many other people with the final boss fight of the Dragonborn DLC. Miraak becomes stuck in the center of the area, tries to absorb dragon souls but they instead become absorbed by my character. I've tried all the "solutions" that I have read in the different forums, but nothing seams to work. Does any know if Bethesesda has acknowledged this game breaking bug? Are they working on a solution? If someone has a definitive way to work around this glitch or any info on a patch release date please leave a message.

    User Info: d4nk82

    d4nk82 - 4 years ago

Top Voted Answer

  1. "We're definitely aware of the glitch, and we haven't denied the issue at all. The issue that you are experiencing is a known issue and we are working diligently to fix it in upcoming patches. Unfortunately at this time we do not have an ETA on when the next patch will be deployed. Aside from loading a previous save file prior to reaching that point in the quest and trying again (which we understand doesn't always work in the case of this particular bug), the best thing to do at this point would be to keep an eye on our forums, as this is the best source of information for emerging issues and patch information."
    They Said that two years ago and I'm still getting the glitch and you cant even kill him with console commands

    User Info: deathsbman

    deathsbman - 2 years ago 1 0


  1. Not sure if i can help, but i defeated miraak on my first attempt. i didnt experience any glitches with it.

    User Info: deewolflvr

    deewolflvr - 4 years ago 0 5
  2. I have the same problem....it's a real bummer that at the peak of the story it stops....please help

    User Info: Lolman1231

    Lolman1231 - 4 years ago 0 0
  3. I had the issue first go, so reloaded.
    He stuck in the middle (again) but this time I used Dragonrend on one of the dragons fliyng around, killed it and he came out of the centre. Give that a go!

    User Info: TheyCallMeMrS

    TheyCallMeMrS - 4 years ago 0 0
  4. If all else fails, like the advice the rest of the ppl have provided. Try not to kill any of the dragons. He needs three dragons to pop out of the middle. I too had the issue of him being stuck in the middle and this is what worked for me. I hope it works for you too.

    User Info: vRDXv

    vRDXv - 4 years ago 0 0
  5. The problem is Miraak doesn't absorb the dragon souls, my character does. I've tried not hitting the dragons, hiding, reloading countless times, and pretty much every other method I've found online. I did just read a post where a person said that if Miraak doesn't steal souls from you while playing the regular game, he won't absorb them when you fight him. So apparently he was supposed to be stealing them from me prior to the boss fight. This never happened while I was playing. Every time I fought a dragon and defeated it my character absorbed the soul. This person said Miraak appears and steals the soul from you. Can anyone else confirm if this is true?

    User Info: silva1234

    silva1234 - 4 years ago 0 0
  6. Yes Miraak does steal souls from you but its not a necessity otherwise it wouldn't let you go to the summit otherwise, and the best solution is a save and reload, as this glitch happened to me, i loaded a save just before i boarded the dragon and did the fight again straight through.

    User Info: bluedragon619

    bluedragon619 (Expert) - 4 years ago 1 0
  7. Silva,
    There is a quest where you go with Nelath to a dwarven ruin,when you exit it and complete it,a dragon appears(has a name),once you kill it,Miraak comes out of nowhere,says some stuff,and takes the soul. Thats what they meant.

    User Info: Shadamence254

    Shadamence254 - 4 years ago 1 0
  8. I found a possible fix for the glitch involving Miraak, I believe I discovered the actual cause of the problem after some lengthy experiments. My first playthrough of the DLC was glitched like alot of others. Where Miraak does not absorb the soul, therefore, gains no health and stays ethereal. I tried all methods known. Sneaking for him to regain health then reattacking him once hes out of the state. However, he repeats the same process of going Ethereal and attempts to absorb the soul of a Dragon that is already dead. I've tried punching. Doing small amounts of damage. Killing all the dragons first. Not killing the Dragons. But the result was all the same. Frustrating, I deleted the DLC and patch and redownloaded. After which, I reloaded a save prior to starting the DLC. I discovered that if the cultists discover you elsewhere, on the DLC island, rather than skyrim then for some reason, Miraak would not appear and absorb souls. In my reloaded save, after reinstalling the patch and DLC, and having progressed enough into the main questline prior, I was almost immediately approached by the cultists where as in the glitch with the absorbing all dragon souls, I traveled there by boat without meeting the cultists in the cities of Skyrim and instead met them on the island. On my second playthrough, having met them in the cities of Skyrim, Miraak appears as normal absorbing souls of Dragons. Thus, he was able to absorb souls in the final battle, though I kept from overdoing the damage just to keep it safe. I know its a pain but restarting the DLC after redownloading both it and the patch and meeting the cultists in skyrim and not turning the first dragon you kill after meeting Miraak to ash seemed to solve the problem, allowing a finishing of the DLC. I hope this helps.

    User Info: Souludus

    Souludus - 4 years ago 0 0
  9. I received an update from Bethesda Support today in regards to my query:

    "We're definitely aware of the glitch, and we haven't denied the issue at all. The issue that you are experiencing is a known issue and we are working diligently to fix it in upcoming patches. Unfortunately at this time we do not have an ETA on when the next patch will be deployed. Aside from loading a previous save file prior to reaching that point in the quest and trying again (which we understand doesn't always work in the case of this particular bug), the best thing to do at this point would be to keep an eye on our forums, as this is the best source of information for emerging issues and patch information."

    User Info: JacobMarley

    JacobMarley - 4 years ago 0 0
  10. Once miraak gets to 1/3 his Hp do weak damage so as to lower his Hp slowly. If his Hp drops to low before he absorbs a soul he will not recover his Hp fully and will stay in ethereal. At least that what I noticed while fighting. Ignore his dragons and fight this way to avoid the glitch. This worked 4 me anyway.

    User Info: BigBoss7734

    BigBoss7734 - 4 years ago 0 0
  11. (XBOX 360 Fix) You can just use Bend Will (level 3) AGAIN on the tamed dragon, causing him to land and enabling the ability to ride him, then mount and ride the tamed dragon and kill the other two dragons while flying (use magic), then allow Miraak to kill the 3rd and final dragon that you are riding (while you are still riding it [make sure you're over the platform!]). This bypasses his ethereal recovery state altogether, sidestepping the glitch, and finally ending him. Tested, 100% working.

    User Info: Raidestric

    Raidestric - 4 years ago 0 0
  12. Ironically the easiest way to beat this guy is not beat him up too hard. do not bring his health all the way down, instead back off when he has a small portion left and let him absorb dragon souls . if you do this all three times he will not glitch .

    User Info: securitron-

    securitron- - 4 years ago 0 0
  13. The key is to not attack him at all, but rather to kill all the dragons first. See here:


    User Info: RG19ninety

    RG19ninety - 4 years ago 1 0
  14. Late to the party, but I'll confirm RG19ninety. Although I didnt watch the vid, I killed all three dragons without making him prompt himself to do so. The first dragon didnt spawn, and it didnt heal him all the way. So I killed the second dragon, which did get him to full health and out of ethereal. So then I chucked iron arrows (had about 2k) at the last dragon til it died, then I killed Miraak, and everything was as screwed up as it always was in Apocrypha. But without glitches/bugs.

    User Info: Aericron

    Aericron - 3 years ago 0 0
  15. I finally figured it out. Disable any Unofficial patch, SkyUI and any ragdoll mods.

    User Info: Dragonslaya197

    Dragonslaya197 - 2 years ago 0 0
  16. Actually, maybe don't disable SkyUI it seems to cause quite a bit of crashing.

    User Info: Dragonslaya197

    Dragonslaya197 - 2 years ago 0 0
  17. For me my glitch is when miraak is impaled by hermaeus mora then the altar rise his corpse cannot be looted (Gone inside altar) so i must use console command to fight him in other place

    User Info: Mathstick

    Mathstick - 2 years ago 0 0
  18. I experienced the same problem. I really did nothing to fix it but leave the game running when Miraak entered his Etheral form to search for possible answers to the glitch. I killed all the dragons and when Miraak got stuck in the Etheral form again I just let him sit there while I tried to search for an answer. I heard Miraak talk a couple times while I was searching. After about ten minutes or so he just came out of the Etheral form for no reason at full health. I'm not sure why but it worked for me.(I would have just reloaded a save but all my autosaves are turned off and I'm one of those guys who doesn't save until I decide to put down the controller.)

    User Info: ImAFloatingHead

    ImAFloatingHead - 2 years ago 0 0
  19. I dont know if this is relevant anymore but I was stuck in the same place for a week and tried possibly everything without success of getting Miraak away from the middle to continue fighting.

    Well, I saw somewhere a hint to disable all unofficial patches (dragonborn, dawnquard etc..) and tada. Loaded save from just before fight starts and everything went JUST RIGHT. He absorbed dragon souls to heal and battle went on normally. I killed him, end of story. I was so happy.

    Then again if you have the problem and you DONT have any of those patches installed then it sucks and I dont know how to help :(

    User Info: sitruunapuu

    sitruunapuu - 2 years ago 0 0
  20. I had the problem where miraak never appeared to steal Dragon souls and when I fought him I'd absorb the soul and he'd stand there stuck in ethereal. I tried every method but nothing worked. Apparently, installing dragonborn before the 1.8 patch is what causes this problem, so the only way to get out of it is to uninstall dragonborn. Reset the dlc by saving the game whilst in skyrim and then load this save once Dragon born has been uninstalled, you won't lose any levels but all dragonborn related items and shouts etc will disappear. Then reinstalling the Dlc will fix the glitch. If miraak appears to steal any Dragon souls after you meet him for the first time, then you know he is not glitched anymore. I can't source because I can't remember where I read this but unfortunately if you installed the dlc and then patched to 1.8 or above after realizing it doesn't run on anything less then there is no other choice, Dragonborn MUST be installed after you have patched skyrim. I tried this begrudgingly but it did fix the problem. Not cool Bethesda.

    User Info: dudeshpiglo

    dudeshpiglo - 2 years ago 0 0
  21. ok first off if you're like me and you like to create weapons that do an insanely amount of damage, then thats your problem lol, if you hit me or I can put his health almost completely down then it takes two dragon souls for him to come out of ethreal he must come out 3 times, and there's only three dragons, so you have to use a lower powered weapon and attack him until he decides to run, when he does he's only going to need one Dragon Soul to refill his health, so after that attack and kill him again with the same weapon, he is going to run and hide and do the same thing again, so there's no need to keep restarting your game or deleting your patches or updates it wasn't Bethesda messing up the game, it was us lol

    User Info: GamingTattooist

    GamingTattooist - 2 years ago 0 0
  22. also there is the problem though that sometimes there aren't three dragons there lol which in that case yeah you have to reload before you entered the different realm and try again, I also realize though that sometimes there's a dragon latched onto the side of the tower almost tricking you making you believe that there's only two dragons

    so I don't know but I don't suggest deleting all your deal see you in patches I didn't have to do any of that I just used a normal weapon and attacked him (with my Armor that has a 37,936,096 Rating soooooo yeah lol)

    User Info: GamingTattooist

    GamingTattooist - 2 years ago 0 0
  23. ----------------------------->FIXED<------------------------------
    if you want to fix this bug first of this can only be fixed by console commands on a PC.
    so want you want to do is when he goes ethereal in the middle of the arena go up to him press this button on your keyboard ~ (located at the top left for me) and a black typing screen should pop up.(to close it simply press the key again)
    then once ur close to Miraak with the console command station open click on him with you mouse and some could should appear in the black box at the top middle say something like 004a455 or like that(its basically the code for the object in skyrim) and type resurrect. this should heal him and he should stop being ethereal but after he has claimed another dragons life repeat this process until Hermaus Mora shows up and kills him. this is quite simple but u can get it muddled up ill attach a link to a video showing how to resurrect someone in skyrim.

    User Info: Never_Kal

    Never_Kal - 2 years ago 0 0
  24. Uncheck the Unofficial Skyrim Patch in data files on the launcher. Then, after killing Miraak, turn it back on.

    User Info: kattdjur

    kattdjur - 2 years ago 0 0
  25. i has this exact same glitch and after a while i managed to fix it but unfortunately this fix only works on the pc so soz to all x-box, ps3 and other users of other devices.

    so what i did when miraak went ethereal in the centre i opened up the console commands( TO DO THIS U NEED TO PRESS A BUTTON THAT LOOKS LIKE THIS
    -------> ~ <---------------- I JUST USED THE ARROWS TO POINT. FOR ME IT IS LOCATED AT THE TOP LEFT OF MY KEYBOARD BELOW ESCAPE AND ON THE LEFT OF THE KEY LABELLED 1 if you do this correct a black rectangle will open up at the bottom of your screen) now make sure u open this up when ur standing a couple feet away from him then move you mouse over his body to the centre of him and left click then some letters and numbers should pop up in the top middle of the console command box and then type these following commands

    first type

    then type

    once u have done this exit the console command box by pressing the button you used to open it and miraak should come back to life and every time he goes ethereal in the centre for a long time just repeat this process

    User Info: Never_Kal

    Never_Kal - 2 years ago 0 0
  26. PC only fix do resurrect 1 make sure to click on him and do 1 this should heal him enough

    User Info: Luker12

    Luker12 - 2 years ago 0 0
  27. Edit he will stop using weapons for a short while making it a little easier

    User Info: Luker12

    Luker12 - 2 years ago 0 0
  28. When Miraak stand at the center and absorbs dragonsouls, the problem is he doesn't become
    full hp. The battle is scripted. So, Miraak must become full hp. But there is no way he couldn't do that himself. Therefore, u have to use cheat code to refill his hp. Type console and click Miraak. And then type resethealth. Miraak will become full hp and he will be out of ethernal form. Then he will attack you again. Do that process 3 times as Miraak absorbs from 3 dragons. You will be fine and there will be no further side effects. If my advice work just thumb up my fri.

    User Info: TravisYM

    TravisYM - 2 years ago 0 0
  29. I bypassed this glitch by using dragonrend on the reptilian dragon from the very beginning of the fight killed him a few times then used bend will on him. And instead of getting off the dragon I stayed on him the whole fight until Miraak knocked me off. Then when I used bend will on the other dragon and did the same thing until he knocked me off then it let me kill him. Dont ask me how it worked it just did??? And it sure as hell beats risking uninstalling your patches which could corrupt your game file making you start from the beginning.

    User Info: Djkurruption

    Djkurruption - 1 year ago 0 0
  30. Cant Defeat Miraak Glitch Fix

    1. Fight Miraak until he become ethereal at the center.
    2. Kill all 3 of his Dragon (either he can absorb soul or he cant. Absorb all dragon souls, you can use it afterwards to add perks)
    3. Notice you cant kill him. Open console command type "SetObjectCompleted DLC2MQ06 520 1"
    4. Open console command type "setstage DLC2MQ06 550" (Notice your quest completed but still Miraak alive, cant loot him, and cant proceed to next scenario)
    5. Open console command type "setstage DLC2MQ06 580" (Podium appears at the center with black book, but Mirraak still alive)
    6. Open console command type "killall" (and now his dead dumb bastard!He is cheating, so to defeat him cheat him too, his not the only Dovakin. Afterwards you can loot him)
    7. You're good to go! look at your back see those floating Skills you can use your dragon souls to exchange it to perks. :)

    Hope it will help. Ive tried many fix for this but fails, until i analyze the use of console command.

    User Info: markandrian11

    markandrian11 - 1 year ago 0 0

This question has been successfully answered and closed.