Archaeologist quest can't give her scroll?

  1. Tried everything including gifting and starting over quest.

    User Info: ann1224

    ann1224 - 9 years ago
  2. Additional Details:
    Well I finished the main quests and it started the archaeologist quest over again, but I still had the scroll and it still won't let me give it to her.Arrrggg!!

    User Info: ann1224

    ann1224 - 9 years ago
  3. Additional Details:
    I finally beat the main storyline and still no luck.I have exactly what she asked for and still no go,oh well,was still a fun game,sure wish I could have gotton that quest done though.Guess I'll start over with a new character .

    User Info: ann1224

    ann1224 - 8 years ago

Top Voted Answer

  1. Yeah same thing happened to me. I got the scro before going to the spire. When I got back, she wouldn't take it =( hopefully a patch will fix that

    User Info: SomethingSnake

    SomethingSnake - 8 years ago 2 0


  1. Either
    A. Wait for another patch to fix that
    B.Just continue on doing other quests

    User Info: silverneo188

    silverneo188 - 9 years ago 1 0
  2. You may not be far enough in the game. Or something has happened with your file.
    Stand around and wait for her o ask you, maybe?

    User Info: GamerrGirll

    GamerrGirll - 8 years ago 0 1
  3. Maybe the quest isn't selected when you go to her......did you try that?

    User Info: AbBy133

    AbBy133 - 8 years ago 0 0

This question has been successfully answered and closed.