Arrow of Extrication help?

  1. In the Thieves Guild quest "Arrow of Extrication", I was told that the Grey Fox would meet me at a certain house, but when I get there, he is nowhere to be found. Do I have to start my game over, or is there a way to make him show up (i.e. raising infamy)? If so, how?

    User Info: Anthony_Wallace

    Anthony_Wallace - 8 years ago
  2. Additional Details:
    I think I've fenced over 1,300 gold of stolen items (definitely over the 1,000 needed to even get the quest). When I enter the house, the arrow changes from red to green so I know I'm at the right house, and I always try at random times. Is the game glitched?

    User Info: Anthony_Wallace

    Anthony_Wallace - 8 years ago
  3. Clarification Request::
    Give me your e-mail and i will notify you of what works and what doesn't.
    My e-mail is
    IF you don't want to give out your e-mail, mine is there if you have any questions you may need accurate help with.
    I answer questions every day and every night because i play oblivion non-stop so i know more than most.

    User Info: Death_Master911

    Death_Master911 - 8 years ago
  4. Additional Details:
    I tried what you said Wisp. Used Night-Eye and no Gray Fox, I'm thinking it's glitched. Unless I was supposed to show him the "Instructions for the Cowl" from the Blind Monk place? I didn't have it on me when I went back to him after getting what I was supposed to get from there.

    User Info: Anthony_Wallace

    Anthony_Wallace - 8 years ago

Accepted Answer

  1. I apologize for the stupidity of this answer if your problem is actually a glitch, but one of the main problems is that the Gray Fox blends in to the background too much. If you can't see him switch to night-eye and it should make character outlines much easier to see. If he is definitely not in the house its probably a glitch...

    User Info: Wisp3112

    Wisp3112 - 8 years ago 1 0

Other Answers

  1. Well perhaps you havent stolen enough? And also try to come at a different day and time. lastly, make sure your at the right house. If none of these work, im afraid your games glitched so good luck

    User Info: maleman24

    maleman24 - 8 years ago 0 2
  2. Stay in the same place and continually make your character wait eventually a messenger will arrive to tell you that the gray fox wants to see you

    User Info: insane1ooo

    insane1ooo - 8 years ago 0 2
  3. I have the same problem, and i have tried pretty much EVERYTHING, i've stolen plenty and fenced plenty, although i'm not sure about the infamy thing, i'll give it a try tonight and let you know if it works, if not then yes you're save is glitched and you have to start all over again. I've also tried waiting in the house constantly, i've tried different times of the day and the night, i had a similar problem except with Armand, i couldn't finish the Bust of Llathas quest because he wouldn't show up no matter how much i waited, i had to reload my save and do it all over again, i think it had to do with the tax collection thing because i woke Heironomous Lex during it and it must've caused a glitch.
    If the Infamy thing doesn't work then yes you and i will both have to start all over again but because i don't want to complete the game again and all that, just do Thieves Guild quests and once you're Grandmaster you should have the Achievement, besides the Gray Cowl he wears is actually stolen property and also the rightful property of Nocturnal, and you know it's Nocturnal because if you go into the Arch-Mage quarters and read Traven's song or something like that it will say something about some guy saying to Nocturnal, "Whereth be thy hood, shadowy hag?" and Nocturnal replies saying that man has stolen it from her, the rest you don't get to find out as it is only a fragment of the song/story or whatever it is.

    User Info: Death_Master911

    Death_Master911 - 8 years ago 1 0
  4. One thing that helped me with my 'Armand Christophe' problem was giving the game a 2 week break, only then did it start working properly.

    User Info: Death_Master911

    Death_Master911 - 8 years ago 0 0
  5. Simple as i said before You're probably GLITCHED.

    User Info: Death_Master911

    Death_Master911 - 8 years ago 0 0

This question has been successfully answered and closed.