whats wrong? "Take it back" glitch

  1. Im on the last part of the game and the robot wont move after it blows up the aircraft. what should i do

    User Info: santas_fury

    santas_fury - 8 years ago


  1. Have you tried pressing forward? Sometimes it will just sit there and wait for you to advance.

    User Info: pizzasoup

    pizzasoup - 8 years ago 0 0
  2. The same thinh happened to me i think its a glitch i relaoded a save and it worked so try relading an older save

    User Info: ApocalypticFire

    ApocalypticFire (Expert) - 8 years ago 0 0
  3. Yep...Same thing happened to me. I guess it's a common glitch. Just reload the auto save from when you leave the Citadel if you don't have a save during the battle and it should work just fine.

    User Info: Zaggmeister

    Zaggmeister - 8 years ago 0 0

This question was asked more than 60 days ago with no accepted answer.

Answer this Question

You're browsing GameFAQs Answers as a guest. Sign Up for free (or Log In if you already have an account) to be able to ask and answer questions.