I can't proceed on Mothership Zeta?

  1. I've progressed most of the way through Mothership Zeta and I'm at the start of the "This Galaxy ain't big enough" quest. However when I go through the decompresion and activate the teleporter, nothing happens. It tells me to proceed to the bridge, but the door remains lockedand according to the guides all the people from downstairs should come through. They don't and I stand there with nothing to do. Any ideas how to fix this? I've tried loading an earlier save several times but the same thing keeps happening.

    User Info: o0VanillaBear0o

    o0VanillaBear0o - 8 years ago

Top Voted Answer

  1. This is a known bug with no known cure.

    Have you tried turning your Xbox off and then on again?

    User Info: itwizz

    itwizz (Expert) - 8 years ago 1 0


  1. I turned my xbox on then off and it worked fine after that. have a back up save incase it doesn't work.

    User Info: Mackie180

    Mackie180 - 8 years ago 0 0

This question has been successfully answered and closed.

More Questions from This Game