Courtesans Guild Glitch?

  1. I was starting to complete guild challenges, and as I was doing the Courtesans "Guards killed during a smoke bomb attack," it glitched (i guess) and now I have 21/20 and it's not counted as complete.

    I have tried everything to get it back down below 21/20, nothing worked. Is anyone else having a problem with this?

    User Info: Pheliont

    Pheliont - 6 years ago


  1. The same thing has happened to me with a Thief Guild challenge for picking pockets, it says I have 1211/250. I can't do anything about it either. Since this seems like this is same problem is popping up for different challenges and it's fairly widespread, maybe Ubisoft will patch it.

    User Info: twosage

    twosage - 6 years ago 0 0
  2. I don't know if it's the same problem or not, but I've had trouble with the "jump from a horse to a beam" challenge, it's stuck at 1/20 no matter what I do. I've seen glitches like this in other games before and I've tried almost everything I can think of, my last idea is to complete another Thieves' Guild challenge and see if that somehow resets the system, but I'm a bit skeptical about that too. I agree with twosage, I think it's something Ubisoft will have to take care of, and we can only hope that they work quickly on it.

    User Info: Hunter_Zero72

    Hunter_Zero72 - 6 years ago 0 0
  3. @HUNTER_ZERO - - - - im not too sure about the glitches for pick pockets. and maybe you figured it out already, but the "jump from horse to beam" has to be done perfect.. in such a manner that Ezio flips up onto the beam after grabbing it.. instead of just grabbing it and pulling himself up.

    User Info: assasindoug

    assasindoug - 6 years ago 0 0

This question was asked more than 60 days ago with no accepted answer.

Answer this Question

You're browsing GameFAQs Answers as a guest. Sign Up for free (or Log In if you already have an account) to be able to ask and answer questions.

More Questions from This Game