Ongoing armor glitch?

  1. Alright, I finally got the Brutus armor after beating the game. All was well until I noticed I was taking A LOT of damage from hits and falls. When I looked at my armor details, I noticed there a was a little flashing red X linked to my shoulder piece. I've never had broken armor in-game, but I think that's what it was saying. Thing is, the menu still says the armor is not damaged and I can't repair it. I've tried switching back to other armor sets, but the red x on my shoulder pauldron still persists.

    This is affecting my health bar too. When I'm playing, my bar is never "full" so to say. I can eat medicine after medicine and never hear the full heath tone. The 'Heal Now' option at doctors doesn't work either. I'll click it, get the pop up saying I'm healed, but it doesn't do anything and I can keep selecting 'Heal Now'.

    Any ideas on how to fix this?

    Notes: I had my game installed on my harddrive when this happened. I've deleted it, played from the disk and still no luck.

    User Info: agt_ferret

    agt_ferret - 6 years ago
  2. Additional Details:
    As I've stated, the armor is not damaged or broken. Unless it's the armor of Brutus, which still has the little 'x', it can still get damaged or broken over time. I've repaired countless times, still the little x persists.

    User Info: agt_ferret

    agt_ferret - 6 years ago


  1. Have you tried to visit a blacksmith and see if you can repair the armor? This might solve it for you.

    User Info: bobbychez

    bobbychez (Expert) - 6 years ago 0 1

This question was asked more than 60 days ago with no accepted answer.

Answer this Question

You're browsing GameFAQs Answers as a guest. Sign Up for free (or Log In if you already have an account) to be able to ask and answer questions.

More Questions from This Game

Question Status
Can someone help with my health glitch? Unresolved
DLC glitch? Unresolved
Map glitch? Unresolved
Glyph glitch? Answered
Where did the Brutus Armor go? Unresolved